InterSystems Oficial
Angelo Bruno Braga · Jun. 30

Lançamento do IAM 2.8.1

Lançamento do IAM 2.8.1 

A versão 2.8.1 do API Manager (IAM) da InterSystems se encontra agora disponível (GA).  Adicionalmente a uma série de melhorias de performance e correção de bugs, esta versão adiciona novas significantes funcionalidades, incluindo:

  • Núcleo
    • Grupos de Consumidores - Permite que você agrupe os consumidores para criar níveis de serviço
    • Ganchos de Eventos - Habilita o acionamento de um web hook por parte do IAM, na ocorrência de eventos específicos. Por exemplo, enviar uma mensagem ao PagerDuty no caso de falha de um endpoint.
    • Melhorias no Modo Híbrido - Checagem de versão relaxada. O control plane pode continuar trabalhando se a base de dados estiver fora.
  • Novos Plug-ins
    • JQ - Aplique transformações às mensagens JSON.
    • OPA - O Open Policy Agent é um padrão da indústria para descrever as políticas de acesso e segurança de uma forma padronizada
    • Mocking - O plug-in Mocking acelera as práticas de desenvolvimento API-first.
  • Console de Administração
    • Filtros e Classificações
    • TLS 1.3 para o Portal de desenvolvimento

O IAM é um gateway de API entre os servidores IRIS da InterSystems e aplicações, disponibilizando ferramentas para monitorar, controlar e gerenciar o tráfico baseado em HTTP com eficiência e em escala. O IAM está disponível como um adicional gratuito a sua licença do IRIS da InterSystems.

O IAM 2.8.1 pode ser baixado na área de Componentes da página de Distribuição de Software do WRC

Acompanhe o Guia de Instalação para orientação de como baixar, instalar e se iniciar no IAM. A documentação completa do IAM 2.8.1 fornece maiores informações sobre o IAM e sua utilização com o IRIS da InterSystems. Nosso parceiro Kong disponibiliza documentações adicionais em como utilizar o IAM na documentação do Kong Gateway (Enterprise) 2.8.x

O IAM está disponível apenas como OCI (Open Container Initiative) também conhecido como formato Docker contêiner. As imagens de contêineres estão disponíveis para mecanismos de tempo de execução aderentes ao OCI para Linux x86-64 e Linux ARM64, conforme detalhado no documento de Plataformas Suportadas.

 

O identificador desta versão é IAM 2.8.1.0-3. 

Este lançamento é baseado no Kong Gateway (Enterprise) versão 2.8.1.

0
0 10
Discussão (0)1
Entre ou crie uma conta para continuar